Step by Step guide: Create an Interactive Dashboard
With SAP Crystal Reports 2020
When Crystal Reports was initially released in the mid 1980s, the term “dashboard” strictly referred to a combined set of gauges that were useful only when you got in a car. And, while you may think that newer toolsets that specifically include “dashboard” in the product title or marketing materials are the only available tools for newer forms of Business Intelligence, SAP Crystal Reports is completely capable of creating visually appealing, interactive BI dashboards.

DASHBOARD DEFINED
While the term "dashboard" can have as many definitions as there are toolsets that create them (and, ignoring the fact that cars still feature them), a general definition of the BI Dashboard is concise and straightforward: A limited set of related, visual elements that present a high-level overview of business or organizational Key Performance Indicators (KPIs) in a single, cohesive screen. There are several immediate points and best-practices to deduce from this definition. When building dashboards with SAP Crystal Reports (or any other product, for that matter), keep some basic best practices in mind:

Keep it concise. Identify only the necessary high-level metrics and KPIs that demand immediate, initial attention. Make use of interactivity to allow drill down to more detailed data behind the metrics. If you find that your dashboard is still too busy or cluttered, create multiple dashboards with a limited number of closely related items on each.

Remember visual best practices. A pie chart with 40 wedges or a chart presenting a bar for every product in your huge inventory won’t be effective. Choose appropriate chart types for specific data scenarios; Make use of Crystal Reports rich charting capabilities to go beyond just pie and bar charts.

Make your dashboards interactive. By nature, a dashboard initially displays relatively little information when compared to a traditional printed report. To get to more detailed data behind the high-level metrics, design drill down hierarchies with grouping, subreports, and hyperlinks.

Make use of SAP Crystal Server. Interactive dashboards are best presented in a simple, interactive web browser. SAP Crystal Server with Concurrent Access Licensing is the perfect environment to maximize Crystal Reports dashboard availability to a broad audience inside, and outside of, your organization.

Ensure high performance. Dashboard interactivity must respond quickly, or users will quickly criticize your work. Particularly with SAP Crystal Server, schedule sluggish dashboards to run during off-hours and present the most recent instance to users. You’ll not only greatly reduce repetitive data source queries, but users will enjoy improved response time!
BASIC NUMERIC METRICS WITH FORMULAS AND GROUP/REPORT TOTALS

Generally speaking, the more use of visual analytics in a dashboard, the greater its effectiveness in drawing and holding your audience. However, in some cases, presentation of basic metric or KPI numbers (but, only if used judiciously), can be a quick way of providing readily visible data to your audience.

For example:
1. Create formulas to calculate year-to-date sales and year-to-date units sold:

![Formula Workshop - Formula Editor - YTD Sales](image1)

![Formula Workshop - Formula Editor - YTD Units](image2)
2. Use the **Insert | Summary** menu option, or the Insert Summary toolbar button, to create a grand summary of the formulas. The summaries should be located as grand totals in the **Report Footer**.

3. To place summaries at the top of the dashboard, drag them from the report footer to the report header. For best visual presentation, add additional annotative items, such as text objects or boxes. Format objects appropriately.
INTERACTIVE DRILL DOWN WITH GROUPS

Interactivity is the key to a successful dashboard. By design, the initial dashboard display is limited to high-level KPIs and metrics. As such, your audience will want to interact with summary elements to get more detailed information “underneath” the high-level values. Crystal Reports drill down accomplishes this via report groups.

There are some helpful tips to keep in mind when designing groups for drill down interactivity:

- Create groups in a logical hierarchy. For example, if you wish to provide drill down from state, to city, to zip code, to individual detail records, create groups in this order:
  - Group 1: State
  - Group 2: City
  - Group 3: Zip Code

- Insert summaries in group footers and annotate, as necessary, with text objects, line or box objects, and formatting. The group footer will be what is initially displayed when that group is drilled into.

TIP: If you wish to have the same summary or total appear in multiple footers (more than one group footer and/or the report footer), you needn’t INSERT SUMMARY multiple times. You may simply select an existing summary and CTRL-DRAG it to the desired section. It will be copied to the new section and will automatically reflect the summary based on the group or report section it was copied to.

- RIGHT-CLICK the desired group footer name to the left of the design area. Select Hide (Drill Down OK) from the context menu. Do the same for the matching group header section.
• If you want your audience to eventually drill into the details section as the last drill down level, select the **Hide (Drill Down OK)** option for the details section as well.

• A **group name field** displays the value of the current group (the current state, city, and so forth). Although group name fields are initially added only to group header sections when you create the group, you may copy or move them from group headers to their companion group footers, or even to other group headers or footers. By copying or moving group name fields, you may more readily identify the drill down hierarchy to your viewer. Using the State-City-Zip Code group hierarchy mentioned previously, you may indicate the current state, city, and zip code being drilled into by copying the Group #1 (State) and Group #2 (City) group name fields into Group Header #3, alongside its group name field.

![Group hierarchy example](image)

• With multiple group drill down hierarchies, group headers may appear when you don't want them to (perhaps repeating over and over with their companion group footers in a higher-level drill down tab). You may conditionally suppress a section based on what level within the drill down hierarchy you want it to disappear.

  o **RIGHT-CLICK** on the desired section name and choose **Section Expert** from the context menu.

  o From the Section Expert dialog box, click the conditional formula button next to the Suppress property.

  o Type in a suppression formula using the **DrillDownGroupLevel** function. Experiment with different numeric values until you achieve the proper suppression of the desired group header or footer.
GROUP AND ADVANCED CHARTS

It has been said that “A picture is worth a thousand words.” One of the main advantages advanced by newer dashboard presentation systems is visual presentation of data. While SAP Crystal Reports presents plenty of opportunities to present data in textual format, newer style dashboards will benefit from data presented in graphical format. Crystal Reports group and advanced charts provide this capability.

**Group Charts** are based on existing report groups, automatically displaying chart elements (bars, pie wedges, and so forth) for each group level with the size of the chart elements based on a group summary field. A big advantage of group charts is drill down capability. A viewer can click on a chart element and drill down on that particular group value.

To create a group chart:

1. Ensure that groups have already been created on the report that you wish the chart to reflect. Drill down behavior can be tested with group name and group summaries prior to creating the group chart.

2. Select **Insert | Chart** from the drop-down menus, or click the Insert Chart toolbar button.

3. An outline of the chart will be placed on the mouse cursor. Drop the chart in a report section one level higher than the group you wish the chart to represent. Using the previously described State-City-Zip Code group hierarchy as an example, if you wish the group chart to show a bar for each state, drop the chart in the report header. Or, if you wish a chart to appear within a state drill down tab showing a pie wedge for each city within the state, drop the chart in the State Group Header #1.

4. RIGHT-CLICK on the chart and select **Chart Expert** from the context menu.
   a. On the **Type** tab, select the most appropriate type of chart based on the data the chart's group represents. Remember visual best practices!

![Chart Expert](chart_expert.png)
b. On the **Data** tab, make sure the button is selected (it should be if you dropped the chart in a group or report header). Then, select the group field you wish to base chart elements (bars, pie wedges, and so forth) on from the **On change of** drop-down list (you may only have one option here, depending on where you dropped the chart). Select the numeric value you wish to use to determine chart element size from the **Show** drop-down list (if you don’t see the desired value in this list, return to the report and Insert Summary using the desired field and re-display the Chart Expert).

![Chart Expert](chart_expert.png)

**Advanced Charts** can be designed around any field in the underlying data source, regardless of any other design elements on the report. When the chart is designed, you may select any field you wish to create elements (bars, pie wedges, and so forth). The size of the chart element can be based on any appropriate field in the data source. Note that you cannot drill down on an advanced chart.

To create an advanced chart:
1. Select **Insert | Chart** from the drop-down menus, or click the Insert Chart toolbar button.

2. Drop the chart in the desired report section, depending on the number of times you wish the chart to appear and the underlying data you wish the chart to summarize. For example, if you place the chart in the report footer, it will appear only once at the bottom of your dashboard and will summarize all the data on the report. If you place the chart in a State group header, the chart will appear the top of each state group, and will summarize underlying data only for the particular state being displayed.

3. **Right-click** on the chart and select **Chart Expert** from the context menu.
a. On the **Type** tab, select the most appropriate type of chart based on the data the chart’s group represents. Remember visual best practices!

![Chart Expert Window](image)

b. On the **Data** tab, make sure the **Advanced** button is selected (if you dropped the chart in a report that contains groups, a group chart may be selected by default). Then, select the database field you wish to base chart elements (bars, pie wedges, and so forth) on from the Available Fields list. Click the **>** button to add the field to the **On change of** box. Depending on the type of chart you selected in the **Type** tab, you may add more than one field to the On change of box. Additional options are available with the buttons, such as the ability to choose the date level for date field, or to chart only the top or bottom N chart elements.

c. Select the database field you wish to determine chart element size from the Available Fields list. Click the **>** button to add the field to the **Show value(s)** box. Depending on the type of chart you selected in the **Type** tab, you may add more than one field to the Show value(s) box. If you wish to modify the type of aggregation the chart will use with the selected field (sum, average, distinct count, and so forth) make desired choices with **Set Summary Operation...** options.
d. Use **Options**, **Color Highlight**, **Axes**, and **Text** tabs to further customize chart appearance.

**TIP:** Whether you create a group or advanced chart, chart appearance and formatting fine points may be modified by RIGHT-CLICKING on the desired chart and selecting Chart Options from the context menu. Even finer control is available by selecting a particular chart element (wedge, bar, label, and so forth) and selecting options from the RIGHT-CLICK context menu.
IN-PLACE AND ON-DEMAND SUBREPORTS

In simple terms, a **subreport** is a report placed within another report. SAP Crystal Reports subreports bring even more flexibility to a Crystal Reports-based dashboard by expanding disparate data source and interactivity options. A subreport can be based on the same data source as the main report, or can be based on a completely different, unrelated data source. And, like the main report, subreports can provide full interactivity with group and chart drill down.

**In-place subreports** display their results within the main report, permitting display of text or chart data alongside objects from the main report. A viewer may not even be aware that textual or visual analytics in a dashboard are coming from a subreport. If the viewer clicks on an in-place subreport, it will redisplay in its own report tab. Within that tab, full report interactivity, such as group or chart drill down, is available.

**On-demand subreports** initially appear as a hyperlink and only display their results when the viewer clicks the subreport link. An on-demand subreport will then appear in its own report tab. Within that tab, full report interactivity, such as group or chart drill down, is available.

To create a subreport:

1. Choose **Insert | Subreport** from the drop-down menus. Or, click the **Insert Subreport** toolbar button. The Insert Subreport dialog box will appear.

2. If a report file already exists that you want to import into the current report as a subreport, **click Choose an existing report** and **Browse** to find the existing .RPT file.

3. To create a new subreport, click **Create a subreport with the Report Wizard**, type in a descriptive name for the subreport, and click **Report Wizard**.

4. The Report Wizard will appear. At a bare minimum, select a data source and add one table. You may also click **Next** to proceed through different stages of the subreport via the Wizard. When you're finished with the Report Wizard, click **Finish**.

5. If you wish create an on-demand subreport to appear as a hyperlink in the main report, check **On-demand subreport (similar to a hyperlink)**.
6. While not required, you may link the subreport to the main report, to permit one or more fields or formulas on the main report to filter the subreport. Click the Link tab and select one or more fields from the main report and match to fields in the subreport data source (if you don't initially link the subreport properly, you Edit | Subreport Links from the drop-down menus later).

7. Click OK to close the Insert Subreport dialog box. An outline will appear on the mouse cursor. Drop the outline where you want the subreport to appear within the main report.

8. A subreport design tab will appear alongside existing report tabs. Select the design tab and proceed to customize the subreport using the same techniques you use for main report design.

9. To continue to design the main report, just click the Design tab. When you refresh or preview the main report, the subreport will appear within the main report.
TIP: While an on-demand subreport behaves like a traditional hyperlink, any report object may also act as a traditional webpage or e-mail hyperlink. RIGHT-CLICK on the desired object, choose Format from the context menu, and click the Format Editor Hyperlink tab. You have many options for different link types. Particularly powerful is the ability to create a dynamic hyperlink with the conditional formula button, permitting you to customize the link on the fly based on a database or formula field.
When finished, an example design tab might look like this:

![Dashboard Example](image1)

With the finished single-page, interactive dashboard appearing like this:

![Dashboard Example](image2)