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Step by Step guide: Learn from sample reports
With SAP Crystal Reports 2020

©
 2

02
0 

SA
P 

AG
 o

r a
n 

SA
P 

af
fil

ia
te

 c
om

pa
ny

. A
ll 

rig
ht

s 
re

se
rv

ed
.



SAP Crystal Reports 2020 is a powerful design tool, providing almost infinite possibilities for creating a large 
variety of printed, on screen, or exported reports. To help you make the most of Crystal Reports features and
techniques, SAP provides a large selection of sample reports free for the downloading. By opening these ex-
isting reports in SAP Crystal Reports and examining how features are used, you may quickly design sophistic-
ated, feature rich reports using existing approaches.

When you first start SAP Crystal Reports 2020, you’ll notice a Start Page that appears in its own tab. If you 
don’t see the start page, choose the Help -> Show Start Page menu option.
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Click Samples and Templates from the Additional Resources column in the middle of the Start Page. A web
browser will be launched and you’ll be prompted to download a ZIP file. Choose the desired location to save
the ZIP file. Use any standard ZIP file utility to expand the contents of the file. Make sure to maintain the
folder structure within the file when you unzip it. When complete, you should find the following file and
folder structure at the target location:

The Demonstration, Feature Samples, Financial, and Versatile and Precise folders contain sample reports in
Crystal Reports .RPT format. The Databases and Report Data folders contain data files that the reports in the
other folders are based on.

Opening Reports with Saved Data
Start SAP Crystal Reports 2020 and choose the File -> Open menu option. Navigate to the location where you 
unzipped the sample files. Continue to navigate to the folder and report file that you wish to explore and click
Open. The report will be opened in its own report tab. Within the report tab, Design and Preview tabs will ap-
pear, with the Preview tab displayed by default. Because the report is saved with data, the Preview tab will 
appear immediately when the report is opened, even though Crystal Reports did not connect to the report’s 
data source to get fresh data. You may confirm that the report is saved with data by verifying that the File -> 
Save Data with Report menu option is checked.
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You may navigate back and forth between the Design and Preview tabs by simply clicking the desired tab.
Many underlying design attributes of the report will only be evident from within the Design tab, so you may
find yourself navigating back and forth between tabs as you explore report features. If you inadvertently close
the Preview tab, you may want to close the report and re-open it from the File menu to re-display the
Preview tab.

NOTE: If you attempt to refresh a report (refreshing refers to connecting the report to its original data
source to view the most current data), you’ll probably encounter an error message or dialog box prompting
for the location of the original data source. Because not all sample data is included in the ZIP file you
downloaded, you will be unable to refresh many reports. You’ll probably be best served by simply
navigating back and forth between Design and Preview tabs with the report still connected to saved data.

Using Techniques For Your Own Reports
Because the sample reports are based on data sources that probably aren’t close in structure to your
production data sources, you won’t be able to directly use the sample reports with your own data. Instead,
the primary way to make use of the sample for your projects will be examining the techniques used to design
a particular sample report and then replicating the approaches in your own reports. There are several
primary techniques and approaches used in the sample reports that you’ll want to examine:
• Grouping and Sorting
• Multiple Report Sections
• Formulas
• Formatting
• Images, Line and Box Drawing

Grouping and Sorting
The order in which items appear in a report is determined by a combination of two report characteristics:
sorting and grouping. Sorting is the more basic technique – it simply determines in what order report details
sections appear. You’ll know you’re viewing a report’s details sections when you see D section names in the
preview tab.
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To see how a sample report’s details sections are sorted, display the Record Sort Expert with either the
toolbar button or the Report -> Record Sort Expert menu option.

TIP: Remember that only details sections are sorted with the Record Sort Expert. If you don’t see D section
names when previewing the report, details sections are either hidden or suppressed and sorting choices
will not have any effect on report appearance. Instead, report grouping will determine the order in which
report data appears.

Far more common, and more powerful, are report groups. Groups not only determine the order in which
items appear, but create “breaks” where data can be subtotaled and summarized. Furthermore, report drill
down is facilitated by creative report grouping. “Nested” groups (groups within other groups) create a logical
“higher-to-lower-level” report organization and drill down hierarchy. You’ll know you’re viewing report
groups when you see group header sections (preceded with “GH”) or group footer sections (preceded with
“GF”) in the preview tab.

To evaluate how a sample report is making use of groups, you’ll benefit by examining placement of report
objects in group headers and footers. Typically, this is best accomplished by displaying the report’s design tab
and looking in various group header and footer sections. It’s also helpful to determine what data fields
various report groups are based on, and what options were selected when the group was created. RIGHT-
CLICK on the desired group header or group footer section (in either design or preview tabs) and select
Change Group from the context menu.
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The Group Options dialog box appears. Here, you may examine what field the group is based on, as well as
various grouping options on both the Common and Options tabs. Make similar use of these features on your
own reports to achieve similar appearance and behavior.

Multiple Report Sections
When you initially create a report, there is only one occurrence of any given report section. For example,
there is only a single details section, single page header, single report footer, and so forth. And, when you
create report groups, there is a single group header #1, group footer #2, and so forth. However, more
advance report capabilities are available by creating multiple occurrences of report sections.

For example, you may benefit by creating multiple details sections and group headers or footers. You may
then add additional report objects into these sections, as well as set a variety of custom appearance and
formatting properties for each section individually.
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To add additional reports sections, RIGHT-CLICK on the desired existing section and select Insert Section
Below from the context menu (typically, you’ll add additional sections in the design tab, but you may do so
from the preview tab if you so desire).

An additional report section will appear below the section you initially selected. SAP Crystal Reports will
append letters to section names as you add them. For example, if your report initially had a single details
section, the report will now include two details sections: Details a and Details b. If you had initially selected
Details b before adding the section, the report will now contain three details sections, labeled a, b, and c.

Once additional sections are added, you may add additional report objects into a section, resize the section,
and set individual appearance and formatting options for the section. Many of the benefits of multiple report
sections come from options set in the Section Expert. As you evaluate the sample reports, display the Section
Expert for a desired section by RIGHT-CLICKING on the desired section name to the left of the section in design
or preview tabs. Select Section Expert from the context menu.

The Section Expert will display the reports section hierarchy on the left. Select a desired section to make
changes to properties in the Common, Paging, and Color tabs. For example, to conditionally suppress a
section so that it only appears under certain conditions, click the conditional formula button to the right of
the Suppress property in the Common tab. Create a formula that returns a Boolean (true or false) value.
When the condition is true, the section will be suppressed.
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Formulas
The key to many report customization features throughout the collection of sample reports is report
formulas. For example, in a sample check printing report, formulas customize the way the check amount
appear, both numerically and as text. By looking at existing formulas in the sample reports, you’ll gain
valuable insight in customization options for your own reports with similar formula logic.

RIGHT-CLICK on the desired formula, either directly on the design or preview tabs, or from the Field Explorer.
Select Edit Formula from the context menu.
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Look at the techniques used in the formula to achieve a result. If you need help on a particular formula
function, keyword, or concept, use Crystal Reports help to learn more about the formula language.

Formatting
As a “pixel perfect” reporting tool, SAP Crystal Reports brings infinite custom appearance options via object
and section formatting. Both techniques are used liberally throughout the downloaded sample reports.

To see formatting properties for a particular report field or text object, select it. Then, view formatting
options on the formatting toolbar. More detailed formatting options appear on the Format Editor. Display it
with a RIGHT-CLICK on the desired report object and selecting the Format option from the context menu.
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Explore formatting options in the sample reports from the Format Editor’s various tabs. For example, to
evaluate how a sample report’s dollar amount is formatted, select the Number tab. If the field has been given
a custom style, click the                              button to display the Custom Style dialog box. Additional tabs here
reveal precise number and currency symbol properties.

In both object and section formatting, look for conditional formatting formulas that have been created. If a
conditional formula button next to a formatting property is displayed in red          conditional formatting
formula has been set for that property. Click the        button to display the conditional formula in the Formula
Editor. Evaluate how you can make use of similar logic for conditional formatting in your own reports.

Images, Line and Box Drawing
Many sample reports include images added to the report for displaying graphical items, such as company
logos or product photographs. To add your own custom images to your report, click the         toolbar button or
use the Insert -> Picture menu option. Once an image has been added, you may select it, RIGHT-CLICK, and
choose Format from the context menu to display the Format Editor for the image.
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As illustrated in many of the sample reports, lines and boxes may be drawn on your report. While displaying
the design tab, use the desired toolbar button                   or Insert -> Line or Insert -> Box menu option.

Remember that lines and boxes may transcend multiple report sections to, for example, surround an entire
report group’s head, encompassing details sections, and footer with a single box. Once a line or box has been
drawn, it may be selected and formatted from the RIGHT-CLICK context menu.
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No part of this publication may be reproduced or transmitted in any form or for any purpose without the
express permission of SAP AG or an SAP affiliate company.

SAP and other SAP products and services mentioned herein as well as their respective logos are
trademarks or registered trademarks of SAP AG (or an SAP affiliate company) in Germany and other
countries. Please see https://www.sap.com/about/legal/trademark.html for additional trademark
information and notices. Some software products marketed by SAP AG and its distributors contain
proprietary software components of other software vendors.

National product specifications may vary.

These materials are provided by SAP AG or an SAP affiliate company for informational purposes only,
without representation or warranty of any kind, and SAP AG or its affiliated companies shall not be liable for
errors or omissions with respect to the materials. The only warranties for SAP AG or SAP affiliate company
products and services are those that are set forth in the express warranty statements accompanying such
products and services, if any. Nothing herein should be construed as constituting an additional warranty.

In particular, SAP AG or its affiliated companies have no obligation to pursue any course of business
outlined in this document or any related presentation, or to develop or release any functionality mentioned
therein. This document, or any related presentation, and SAP AG’s or its affiliated companies’ strategy
and possible future developments, products, and/or platform directions and functionality are all subject
to change and may be changed by SAP AG or its affiliated companies at any time for any reason without
notice. The information in this document is not a commitment, promise, or legal obligation to deliver
any material, code, or functionality. All forward-looking statements are subject to various risks and
uncertainties that could cause actual results to differ materially from expectations. Readers are cautioned
not to place undue reliance on these forward-looking statements, which speak only as of their dates, and
they should not be relied upon in making purchasing decisions.
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